This document is applicable ONLY to Microsoft Server 2003 running 11S 6.0. If any other application is running on the server to support its
function (e.g., Cold Fusion), then that application must also be secured. The steps in this guide should be performed on new installations only
to avoid unpredictable results. This hardening procedure should NOT be used on general-purpose NT servers on an internal LAN (e.g., file
servers), as it removes several of the services that NT uses for default functionality.

NOTE: You should keep the server unplugged from the network until you are told in the guide that it is ok to plug it in.

Step 1.0 — Boot up Windows Server 2003 Standard Edition (Build 3790) CD-ROM to begin installation and
configuration.

Step 1.1 — When the Welcome Screen Appears, press Enter to continue
Step 1.2 — Press F8 to accept the End User License Agreement (EULA).

Note: Install only one instance of the operating system. If you need to get on to a server using another instance, install as needed, and delete
afterwards. If there are any previous versions of operating systems, remove by deleting partitions and repartition.

Step 2.0 — Create a partition for the Operating System.

Step 2.1 — Press C to Create a Partition. In the white space, enter the value of your Operating System partition (this should be at LEAST
6.5GB (6500MB) and more is better) and press Enter to continue.

Step 2.2 — Choose the Partition that you just created with the Up/Down arrows and press Enter to begin the OS installation.
Step 2.3 — Choose “Format the partition using the NTFS file system” and press Enter to continue.

After formatting the hard drive and copying over the necessary files, the OS installation will reboot and continue.

Step 3.0 — Regional Settings

Step 3.1 — Choose regional settings as appropriate

Step 3.2 — Enter the following in the allowed whitespace:

Name of your Organization:
Company:

Step 3.3 — Enter the Product Activation Key



Step 3.4 — Choose the Per Device or Per User radio button

Step 3.5 — Give the server a name. Ensure that you follow the current corporate naming constraints for Servers. In general, the server name
should consist of 3 letters for the Server function, 3 letters for the Server location and 3 numerals denoting the sequential order of the Server.

Example: The first server for the Web Server Farm, residing in St. Louis - WEB-STL-001
Step 3.6 — Set a strong administrator password. Ensure that you follow your company’s guidelines for creating a strong password.
Step 3.7 — Set time and date
Step 4.0 — Network Settings
Step 4.1 — Choose Typical Settings

Step 4.2 — For Workgroup or Computer Domain, choose “No, this computer is not on a network...” In the white space, enter a blank
workgroup (ALT-255).

The OS will now continue configuration. When it is done, it will bring you the Login Screen. Login with the password that you set in Step

3.6. After login, the “Manage Your Server” box will pop up. If you desire, place a check mark in the box labeled “Don’t display this page at
logon” and close the window.

Step 5.0 — Choose Components

Step 5.1 — Go to Start > Control Panel > Add/Remove Programs > Add/Remove Windows Components and select Application Server.



Windows Components Wizard

Windows Components
Yau can add ar remave campanents aof Windows,

To add ar remove a companent, click the checkbox & shaded box means that anly
part of the component will be installed. To zee what's included in a compaonent, click

Detailz.
Components:
.-’-'-.-:u:essu:-ries and Utilites 45ME
& Application Server 24 6 MB
[ [E8 Certificate Services 1.4 MB
] ™ E-mail Services 1.1 MB
22N MR j

[1 & Faw Servires

Descrption:  Includes ASP.MET, Intermet Information Services [[15]. and the
Application Server Conzole.

Total dizk zpace required: 14.1 MB D etails |
E395.0 ME —

Space available on dizk;

< Back I Hewt > I Cancel | Help |

Step 5.2 — If you plan on using SNMP to monitor the Server, scroll down and high-light Management and Monitoring Tools



Windows Components Wizard

Windows Components
Yau can add ar remave campanents aof Windows,

To add ar remove a companent, click the checkbox & shaded box means that anly
part of the component will be installed. To zee what's included in a compaonent, click
Dretailz.

Compaonents:

iﬁ Internet Explorer Enhanced Securnity Configuration
I = - Management and Maonitaring T ool

00ME |

E.1ME

[ 2% Networking Services 2eme |
O EEJ Other Metwaork. File and Print Services 0.0 MB

1 ™ B ernnte Installatinn Serdnes SNme X
Description:  Includes tools for monitoning and improsving netwark peformance.

Total dizk gpace reqqired: 14.1 MB Details... |
Space available on dizk; 6395.0 MB

< Back I Hewt > I Cancel | Help

Click on Details



Management and Monitoring Tools X|

To add or remove a component, click the check box. & shaded box means that only part
aof the component will be installed. To see what's included in a component, click Details.

Subcompanents of Management and Manitaring Toals:

[ %' Cornection Manager Administration Kit 1.1ME ;I
O ﬁ Connection Point Services 0.2 B
| Metwork Manitar Toals 23 MB

™ L Simple Metwork Management Protocol 0.9 MEB

O 'W'MI SMHMP Provider 1.1 MB
| 'W'MI YWindowes [nstaller Provider 0.6 ME

[

Dezcrption:  Includes agents that monitor the activity in network. devices and report to
the network conzole work station,

T otal dizk space required: 15.0 MB Details |
Space available on dizk; 6395.0 MB
(] I Cancel |

Select only Simple Network Management Protocol
Click OK to return to the previous menu.
Step 5.3 — Click Next to begin installation of the Application Server Components.

Step 5.4 — When the Application Server has finished installing, you can click the Finish button to complete the installation and then you can
close the Add/Remove Programs window.

Step 6.0 — Install the latest Patch Releases

As of 10/15/04:

MS04-038 | October 12, 2004 - Cumulative Security Update for Internet Explorer
(834707)

MS04-037 | October 12, 2004 - Vulnerability in Windows Shell Could Allow Remote
(841356) Code Execution



http://www.microsoft.com/downloads/details.aspx?FamilyId=19E69E5F-9C98-49AD-A61F-4F82A4014412&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=5C60CA12-0045-42B7-9F2A-6D433DEDC105&displaylang=en

MS04-034 | October 12, 2004 - Vulnerability in Compressed (zipped) Folders Could
(873376) Allow Remote Code Execution

MS04-032 | October 12, 2004 - Security Update for Microsoft Windows

(840987)

MS04-028 | September 21, 2004 - Buffer Overrun in JPEG Processing (GDI+) Could
(833987) Allow Code Execution

MS04-024 | August 10, 2004 - Vulnerability in Windows Shell Could Allow Remote
(839645) Code Execution

MS04-023 | July 13, 2003 - Vulnerability in HTML Help Could Allow Code Execution
(840315)

MS03-039 | September 10, 2003 - Buffer Overrun In RPCSS Service Could Allow Code
(824146) Execution.

MS03-041 | November 17, 2003 — Vulnerability in Authenticode Verification Could
(823182) Allow Remote Code Execution

MS03-043 | October 15, 2003 — Buffer Overrun in Messenger Service Could Allow
(828035) Code Execution

MS03-044 | October 22, 2003 — Buffer Overrun in Windows Help and Support Center
(825119) Could Lead to System Compromise

MS03-048 | December 11, 2003 - Cumulative Security Update for Internet Explorer
(824145)

MS04-007 | February 10, 2004 - ASN.1 Vulnerability Could Allow Code Execution
(828028)

MS04-011 | April 13, 2004 - Security Update for Microsoft Windows

(835732)

MS04-012 | April 13, 2004 — Cumulative Update for RPC/DCOM

(828741)



http://www.microsoft.com/downloads/details.aspx?familyid=0903569E-7F3D-4846-A1DC-78734E77D3A9&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=206E9842-997D-45E4-9252-61F3CE5EA66C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=B2FBD93C-3DC3-4A9E-BDD6-9F39726EE3E2&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=41C7BB26-3500-4492-A447-33440C404E4F&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=8B53C35D-E9ED-46AD-936C-30C8E3A7E606&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=51184D09-4F7E-4F7B-87A4-C208E9BA4787&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=135D8C00-7B4B-4C21-8EAA-D58814635E0D&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=1DF106F3-7EC4-4EB0-9143-C1E3C9E2F5F8&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=40F25862-A815-4674-9175-E3640E3EFD49&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=7D0D02DD-8940-48E0-B163-3FCDCB558F21&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=3D7FFFF9-A497-42FF-90E7-283732B2E117&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=EAB176D0-01CF-453E-AE7E-7495864E8D8C&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=07317CE9-520D-4574-B575-5FB85DA9A4D7&displaylang=en

Step 6.1 — You may now plug the server into the network.

Step 7.0 — Installing SSH Server for Remote Management

For remote access we will use SSH as the only transport. The software is available below for the server and the client.
Step 7.1 — Download and install an SSH Server and Client Software

We recommend the server and client from http://www.ssh.com/.

Step 7.2 — After installing the server application, open the SSH Secure Shell Server Configuration window:
Go to Start > Programs > SSH Secure Shell Server > Configuration

This will bring up a window that looks like the following:


http://www.ssh.com/

MA: 85H Secure Shell for Windows Servers Configuration x|
S5H Server Settings SSH Server Setti“gs
- General

- Network S5H Secure Shell for Windows Servers wersion 3.2 configuration.
- Erncryption
- |dertit
P. — Server Status
- Tunneling
=~ User Authentication
Pazzward StﬂppEd Start Server
=l Public: Key
- Certificates
“ RS54 SeculD —Ewent Log
- Host R ES"?Dt?D”S The server reparts importatt everts in the system _
- User Restrictions event log. Wiew event log contents with this button,  ¥iew Event Log
(= SFTP Server
“ Power Users )
I e —— Defaulk Settings

Restore facton default zettings with this

button, Bestore Default Settings

k. Cancel

Under the General Tab:

Increase the "Maximum Number of Connections” value to 2

Step 7.3 — Create a new text file called BannerMSG.txt and place it in:

C:\Program Files\SSH Communications Security\SSH Secure Shell Server directory
The file should contain the following verbiage:

WARNINGII'!
READ THIS BEFORE ATTEMPTING TO LOGON

This System is for the use of authorized users only. Individuals using this computer without authority, or in
excess of their authority, are subject to having all of their activities on this system monitored and recorded by
system personnel. In the course of monitoring individuals improperly using this system, or in the course of system



maintenance, the activities of authorized users may also be monitored. Anyone using this system expressly consents
to such monitoring and is advised that if such monitoring reveals possible criminal activity, system personnel may
provide the evidence of such monitoring to law enforcement officials.

Step 7.4 — Link the BannerMSG.txt file that you just created in the "Banner message file" box by clicking on the box with the three dots on
the right of the white space and finding the file in the above named directory.

selectFile 2] x|
Laak ir: I ) 55H Secure Shell Server j - = EH-
| ) Docurnentation

' BannerMSiG, bxk
E] cert-user-mapping. txk
E] License, txt
E] Readrme, bxk

File name: — |Bannerd 3G, bt Open |
Files of type: | Text Files [* ] | Cancel |

The resulting screen should look like this:




MA: 85H Secure Shell for Windows Servers Configuration x|
- General

- Metwork: Configure general zerver settings.
- Erncryption

-~ |dentity b axirnuin number |2— (0= uniimited |

- Tunneling of connections

=- Ll_ser Authentication Ewent log filker
i Password [ Emars

= Public Key _
{ L Certificates ¥ 'wamings

- RS4 SeculD W' Infarmation
- Host Restrictions
- User Restrictions

= SFTP Server [dle timecout [zeconds)] ||:| [ 0= dizabled )

. Power Users
- License Banner meszzage file IE:HPrngram Fil=zh55H Communication:
Termninal provider Iu:mu:l.e:-:e |
Apply (] 4 Cancel

Step 7.5 - Under the Encryption Tab:
Ensure that the following settings are selected:

Ciphers: AnyStdCipher
MACs: AnyStdMac



MA: 55H Secure Shell for Windows Servers Configuration X|
S5H Server Settingz Enc tion
- General yp

- Metwork Configure encryption algaorithms [ciphers] and meszage authentication codes
& E ncryption [MALCs] here. Select one of the predefined options ar specify your own
-~ Identity combination of supported ciphers, separated by commas.
- Tunneling _ :
=1~ User Authentication Ciphers I-‘E'-”-'r'StdE'phE’ j
- Pazsward
=) Public ey talCs I.-'l'-.n_l,lSthan:: j
L Certificates
(- BSA SeculD Rekey interval [zecondsz) ID [0 =dizabled ]
- Hozt Restrictions
- Uszer Pestichions Random zeed fils Isewer_randu:um_seed |
- SFTP Server
‘o Power Users
- License

Apply | | ] 4 I Cancel

Step 7.6 - Under the Tunneling Tab:

Place a check mark in the box next to Allow TCP Tunneling.



MA: 55H Secure Shell for Windows Servers Configuration X|
S5H Server Settingz Tun"EIi"g
- General

- Mehwark Configure tunneling by listing users who can create tunnels.
- Encrpption
- | dentity Allow TCP tunneling v
= User Authentication Allow TCP tunneling for users
i Pazzword '
(105 g s
i e Certificates
- R5A SeculD
- Host Restrctions
- Uszer Restnctions Dery TCP tunneling for users
=~ SFTP Server
o Power Users
- Licenze

Apply ] 4 Cancel

Step 7.7 — Under the User Authentication > Password Tab

Ensure that the "Permit empty Passwords" box is NOT checked.



MA: 55H Secure Shell for Windows Servers Configuration X|
S5H Server Settingz Password
- General

- Netwark Configure pazsword authentication. Please note that the use of damain wser
- Encryption accounts always requires password authentication.
- |dentity
- Tunneling — Pazzword Authentication
- User Authentication -
i word Paszword authentication I.-’-'-.Ilcuw j

F.ey

g o Fermit empty passwordz o
P Certificates
i FSA SecurlD
- Host Restrictions — Keyboard |nteractive

-+ User Restrictiorss Password authentication can alzo be offered through a new generic

B~ S:FTF" Server authentication method called keyboard interactive. Check the boy
i Power Ugzers below to enable it.
- Licenze

[ Run password authentication over kevboard interactive

Apply ] 4 Cancel

Click Apply to make the changes permanent. Click OK to exit.

Step 8.0 — Media Configuration and Permissions

Step 8.1 — Go to Start > Programs > Administrative Tools > Computer Management > Disk Management



O Computer Management O] x|

=] File  pction  Wiew window  Help =]
= | AE 2 BXES
Q Compuker Management (Local)y Yalume | Laviouk | Type | File Stvskem | Skatus | Capacity | f
Eﬁg System Tools = (c) Partition Basic MTFS Healthy (System) 3,91 GB
"@ Event Viewer ZEINRMSYOL_EN(D:) Partition Basic  CDFS Healthry E42ME |
Shared Folders
Local Users and Groups

ool Disk Defragmenter
. o (B E— 1]

Eﬂ--& Services and Applications

E¥pisk 0

Basic {C:)

5,00 GE 3.91 GE NTFS 4.09 GB

online Healthy {System) Unallocated

Z=JCD-ROM 0 e

LD MRMSYOL_EM {D:)

542 MEB 542 MB CDF5

Cnline Healthey

-

*l |_,| B Unallocated | Primary partiticn —1

Step 8.3 - Format unallocated disk space.

In the bottom right panel, Right Click on the section labeled Unallocated (shaded in the picture below) on Disk 0 and choose New Partition.



O Computer Management O] x|
(=] File | Ackion  Wiew  Window  Help =]
- 2 D&
Q Compuker Management (Local)y Yalume | Laviouk | Type | File Stvskem | Skatus | Capacity | f
=- ﬁg System Tools = () Partition Basic MTFS Healthy (System) 3,91 GB
l @ Event Viewer ZEINRMSYOL_EN(¥:) Partition Basic  CDFS Healthry E42ME |
Shared Folders
Lu:u:al Users and Groups
= @ Starage
- Removable Storage
5 ‘. i Disk Defragmenter
‘ 'I Disk Managemenkt 1] | _’I
EEI--& Services and Applications ”
EFDisk 0 —
Basic (C:)
5.00 B 3.91 GB NTFS 4.09 GB
Online Healthy (Syskemn) Unallocated
“=CD-ROM 0 -
DD NRMSYOL_EN (Y:)
542 MB 542 MB CDFS
Cnline Healthy

| »] B Unallocated | Primary partiticn

This will bring up the New Partition Wizard



New Partition Wizard x|

Welcome to the New Partition
Wizard

Thiz wizard helps you create a partition on a bazic disk.

A basic dizk iz a physical dizk that containg primary partitions,
extended partitionz, and logical dives. You can uze any
werzion of Windows or M5-005 to gain access bo partitions
on bazic disks.

To continue, click Mest,

< Back

Cancel |

Step 8.7 — Click Next to continue



New Partition Wizard x|

Select Partition Type
There are three bupes of partitions: primany, extended, and logical. ,

Select the partition you want to create;

™ Extended partition

€ Logical drive

— Description

& primary partition iz a volume pou create uzing free space on a basic disk.
YWindaws and other operating systems can start fram a primary partition. ¥'au can

create up to four primary partitions or three primany partitions and an extended
partition.

< Back I Hest » I Cancel

Step 8.8 — Ensure that Primary partition is selected and click Next to continue.



New Partition Wizard x|

Specify Partition Size
Chooze a partition zize that iz between the mawirnum and minimum sizes. ,
b awium dizk zpace in megabyptes [MEB]: 31259
inirum dizk zpace in MB: a

Partition zize in MB:

< Back I Hest » Cancel

Step 8.9 — Select the size of your partition in MB and click Next to continue.



Create Partition Wizard

Aszzign Dnve Letter or Path
Y'au can aszign a drive letter ar drive path to a partition.

{+ ssign a drive letter: IE: =l

™ Mount thiz volume at an empty folder that supports diive paths:

I Brawse, . |

™ Do not assigh & drive letter or drive path

< Back I Hest » I Cancel

Step 8.10 — Assign it the appropriate drive letter, E: and click Next to continue.



New Partition Wizard x|

Format Partition
To ztare data an thiz partition, vau rmugt farmat it first. ,

Chooze whether yau want to farmat this partition, and if 2o, what zettings you want to uze.

™ Do not format thiz partition

= Fommat this partition with the following settings:

File spstem: INTFS j
Allocation unit size; IDEfauIt j
Yolumne |abel: INEW Yolume

[ Perform a quick format

[~ Enable file and folder compression

< Back I Hest » I Cancel

Step 8.11 — Ensure that Format this partition with the following settings is selected and the values for File System is NTFS and the
Allocation unit size is default. You may change the Volume Label if you desire.

Click Next to continue.



New Partition Wizard x|

Completing the New Partition
Wizard

Yaou have successfully completed the Mew Partition Yizard.

You zelected the following zettings:

Fartition tpe: Primany partition s
Digk zelected: Disk 0

Partition zize: 4183 MB

Dirive letter or path: O

File syzter: NTFS

Allocation unit zize; Default

Wolume label; Mew Yolume j

Muirk Farrmak Ma

To cloze this wizard, click Finigh.,

< Back I Firizh I Cancel

Step 8.12 — After reviewing your selected settings, click Finish to begin the format.

Upon completion, your disk manager should show 2 partitions on Disk 0 as pictured below.



E Computer Managemenkt - |I:I|E|

Q File  Action Wiew Window Help - |E’|5|

c= aE 2 EXEE

Q Computer Managerment (Local) Wolume | Layouk | Ty pe | File System | Skatus | _apacity | Fr

=- ﬁg System Tools m Partition Basic  MTFS Healthy (Systern) 7.81GE A
@ Event Viewer =IMew Yolume (D2 Partition  Basic  NTFS Healthey 30,53 GE 3

! Shared Falders
Local Users and Groups

EI@ Storage
¥ Removable Skorage
& Disk Defragmenter
=0 Disk Managemenkt 1|

[~ & Services and Applications

ZPDisk 0 I

Basic (C:) Mew Yolume {D:)

38-_34 GE 7.81 GENTFS 30,53 GBE NTFS

Orline Healthey (System) Healthy

ZSCD-ROM 0 —

CD-ROM (223

Mo Media

-

a I_pl B Frimany partition

When the formatting is complete, you can close the Computer Management window.

Step 8.13 — Double click on the My Computer icon, Right click on the C: drive and select Sharing and Security
Click on the Security Tab

Step 8.14 — Remove the Everyone Group

Step 8.15 — Click on Add and add the Backup Operators Group and give them permissions for Modify.



Local Disk {C:) Properties 7] x|

Generall Toolz I Hardware Security | I]ul:utal

Group or uzer hames:

E Administrators [DMZ-HARD WAdminiztrators)]

‘ Backup Operators [DMZ-HARDAE ackup Operators)
€7 CREATOR OwWNER -
ﬁ 5_Guest [DMZ-HARDWIS_Guest)

lT Brusar | lears (M7 HARM Prmar | eare] | _Ij
4 ]

|»

Add... | Bemove |

Permizzions for Backup
Operataors Al Dery

Full Cantral (M| o =

b odify O

FRead & Execute O

List Folder Contents O

Read O

Wirite O j

For zpecial permizzions or for advanced settings, Advanced
click Advanced. =

L

k., I Cancel | Apply |

Step 8.16 — Click on the Advanced button and highlight the Backup Operators group that you just added.



Advanced Security Settings for Local Disk (C:) 7] x|

Fermniszions |.-“-‘-.u|:|iting| I:Iwnerl Effective Permissinnsl

T o view mare information about special permizsiong, select a permizzion entry, and then click Edit.

Permizzion entries:

Type | M amne | Permizzian | |nherited From | Apply To |
Deny 15_Guest [DMZ-HAR...  Full Cantral <nok inhernited: Thiz folder, zubfolders. ..
Bllane Administrators [DMZ-...  Full Control <not inherited: Thiz folder, subfolders. ..

Backup Dperators [0...  Special <hat inhented: This falder, subfolders. ..

Al CREATOR O'wWHER Full Cantral <nok inkerited: Subfolders and files anly
Al Power Uszerz [DMZ-H...  Read & Execute <nok inhernited: Thiz folder, zubfolders. ..
Al SYSTEM Full Control <not inherited: Thiz folder, subfolders. .

Allone zerz [DMZ-HARDY...  Read & Execute <not inherted: Thiz folder, subfolders. ..

Add... Edit... Bemove

™ Feplace permizzion entries on all child objects with entries shown here that apply to child objects

Learn more about access control.

k. I Cancel | Apply |

Step 8.17 — Click on the Edit button and ensure that the Backup Operators group has permissions for everything EXCEPT: Full Control,
Change Permissions and Take Control




Permission Entry for Local Disk (C:) 7] x|

Object |
[RE = r stors [DMZ-HARDAE ackup Operators)
Apply anta: | This folder, subfolders and files =l
Permizzions: Allov Deny
[T o oo . = | - ;I
Traverse Folder / Execute File O
Lizt Folder / Read Data O
Fead Attributes O
Fiead Extended Attributes O
Create Files / Write Data O
Create Folders / Append Data O
Wwihite Attibutes O
Wiite Extended Attributes O
Delete Subfolders and Files O
Delete O
Fead Permizzions O —
Change Permizzions O O j

r Apply theze permizsions to objects andor Clear Al |

cohtainers within thiz container anly

] I Cancel |

Click OK when done.

Step 8.18 — Click on the Add button and add the 11S_Guest Group.



Local Disk {C:) Properties 7] x|

Generall Toolz I Hardware Security | I]ul:utal

Group or uzer hames:

ﬁ Administrators [DMZ-HARD WAdminiztrators)] |E=
ﬁ Backup Operators [DMZ-HARDYWE ackup Operators)
€7 CREATOR OWNER -

‘ [15_Guest [DMZ-HARDYIS_Guest]
Peumar | leare (MAZ AR Pear | leare] b
i I LIJ
Add... | Bemove |
Permizzionz for [15_Guest Al Dery
Full Cantral (M| -
b odify O
FRead & Execute O
List Folder Contents (M|
Read O
it O j

For zpecial permizzions or for advanced settings, Advanced |
click Advanced. =
k., I Cancel | Apply |

Step 8.19 — Click on the Deny checkbox for Full Control.

Step 8.20 — Click on the Add button and add the Power Users Group.



Local Disk {C:) Properties 7] x|
General I Tools I Hardware Security | Cuota I
Group or user names:
€7 CREATOR DWNER =]
ﬁ 5_Guest [DMZ-HARDWIS_Guest)
‘ Power Users [DMZ-HARDAPower Users) J
€7 SvSTEM
| lears (MAF HADTL Loare] b
i | LIJ
Add... | Bemove |
Permizzionz for Power Uzers Al Dery
Full Cantral (M| o =
Madify O O
FRead & Execute O
List Folder Contents O
Fead O
Wirite O O j
For zpecial permizzions or for advanced settings, Advanced |
click Advanced. =
k., I Cancel | Apply |

Step 8.21 — Ensure that the Users Group has permissions for Read & Execute, List Folder Contents and Read only.



Local Disk {C:) Properties 7] x|

Generall Toolz I Hardware Security | I]ul:utal

Group or uzer hames:

ﬁ 15_Guest [DZ-HARDAWIS_Guest) ﬂ
ﬁ Power Uzers [DMZ-HARDYWPower U zers]
€7 SvSTEM
‘ Uszers [DMZ-HARDY zerz)
< |
Add... | Bemove |
Permizzionz for Users Al Dery
Full Cantral (M| o =
b odify O O
FRead & Execute O
List Folder Contents O
Fead O
Wirite O O j

For zpecial permizzions or for advanced settings, Advanced |
click Advanced. =
k., I Cancel | Apply |

Step 8.22 - IMPORTANT!! Click the Advanced button and place a check mark in the box labeled Replace permission entries on all child
objects with entries shown here that apply to child objects.

Step 8.23 — Click OK to apply the new permissions.

A security warning should pop up that looks like this:

«

f This will remove explicitly defined permissions on all child objects and enable propagation of inheritable permissions ko
.

i

those child objects. Only inheritable permissions propagated From Local Disk () will kake effect.

Do wou wish to conkinue?




Step 8.24 — Click Yes to continue.

Right before completion, you will receive an Error Warning box:

Error Applying Security El
'T An emar occurred applying zecurity infarmation ko
= C:hpagefile. zpz

The process cannot access the file because it iz being used by
another process.

Cancel |

Step 8.25 — Click Continue to proceed.
Step 8.26 — Click on the Advanced button again and go to the Auditing Tab.
Step 8.27 — Click the Add button and add the Administrators Group and place a checkmark in the boxes for each of the following:

e Create Files/Write Data

e Create Folders/Append Data
e Delete Subfolders and Files

e Delete

e Change Permissions

e Take Ownership



Auditing Enktry for Local Disk {C:) 7] x|

Object |

Marne: Idministratu:ur [ 2K 3-TES T “Adminiztratar] Change... |

Apply onta: | This folder, subfolders and files =l

Aooess Successful  Failed
T AT T T T R

Lizt Folder / Read Data

Read Attributes

Fead Extended Attibutes
Create Files £ Write Data
Create Folders / Append Data
Wiite Attibutes

Wiite Extended Attibutes
Delete Subfolders and Files
Delete

=

IDREO0REOO0C

Read Permizsions

Change Permizsions

EEOREOO0REOOOC

T ake Dwnerzhip

r Apply theze auditing entries to objects Clear Al |

and/or containers within thiz cantainer anly

] I Cancel |

Step 8.28 — Repeat steps (8.26 - 8.27) for the Power Users Group and the Backup Operators Group.

Step 8.29 — For the E:\ partition, repeat the above steps (8.14 - 8.27) with the exception of the following permissions:



New Yolume {D:) Properties 7] x|

Generall Toolz I Hardware Security | I]ul:utal

Group or uzer hames:

ﬁ N5_Guest [DMZ-HARDAIS_Guest) ﬂ
‘ Power Uzers [DMZ-HARDWPower U zers)

€7 SvSTEM
€7 Users [DMZ-HARD \Users)
1| | ¥

Add... | Bemove |

Permizzionz for Power Uzers Al Dery

Full Cantral o =

b odify O

FRead & Execute O

List Folder Contents O

Fead O

Wirite O j
For special permiszions or for advanced settings, Advanced |
click Advanced. =

k., I Cancel | Apply |

Give the Power Users group, full access to this partition.

Step 8.30 — Repeat the above steps (8.14 — 8.27) for all additional disk partitions.
Step 8.31 — Click Apply then click OK

Step 9.0 — Turn off Indexing on all Volumes

Step 9.1 — Under the General Tab, uncheck the box marked Allow Indexing Service to index this disk for fast file searching



Local Disk {C:) Properties 7] x|

Security I Shadow Copies I [luoka
General | Tools I Hardware I Sharing
Type: Local Digk.

File spztern: ~ MTFS

. |lzed space; 2.155.413.504 bytes 200 0GB
. Free space: 2.039,443 456 butes 1.89GE
Capacity: 4 154 856,360 bytes 390 GE

|

Dirive C Dizk Cleanup

™ Compress dive to save disk space

[ Allow Indexing S ervice bo index this disk for fast file searching

k. I Cancel Apply

Click OK

A confirmation box reading Confirm Attribute Changes will pop-up.
Step 9.2 — Choose Apply changes to C:\, subfolders and files.

Step 9.3 — Repeat this procedure for all other hard drive partitions.
Step 10.0 — Virtual Memory Settings

Step 10.1 — Right mouse click on the My Computer icon and choose Properties and go to the Advanced Tab.



Step 10.2 — Under the Performance subsection, choose Settings and then click on the Advanced Tab.

Step 10.3 — Under the Virtual Memory subsection, choose Change.

Step 10.4 — Under the Paging file size for selected drive, ensure that Custom size: is selected and set the Initial and Maximum size to be the
same (use the Maximum figure as the value).

¥irtual Memory ed |
Drive [Molume Label] Paqing File Size (ME)

[Mesw volurne]
[GHARED FOLDERS]

ey 1

—Paging filz size for selected drive
Dirive: s
Space available; 2706 ME

¥ Cuskam size:

Initial size (ME): I 1536
Maximum size (ME): I 1536

(8 System managed size

" Mo paging file Set

— Total paging file size Far all drives
rinirurn allowed: 2ME
Recommended: 766 ME
Currently alocated: 768 ME

I Cancel

Step 10.5 — Click the Set button.
Step 10.6 — Repeat these same steps (10.1-10.5) for all other volumes.

Step 10.7 — Click OK to get back to the System Properties window.



Step 11.0 - Installing the Anti-Virus Engine
Step 11.1 — Download a Virus Scan Engine of your choice. We recommend McAfee and this guide details the installation of that.
Step 11.2 — Create a folder and extract the Virus Scan Engine into it.

Step 11.3 — Go to the folder that you extracted the file to and double click on vse700.msi

i'g!,'l McAfee ¥irusscan Enterprise Setup 5[

McAfee VirusScan Enterprise Setup

This setup wizard will install McAfee YirusScan Enterprise to your server or workstation, Before
continuing, please review the following product information.

McAfee VirusScan Enterprise =

Version 7.0.0
© 2003 Metworlks Associates Technology, Inc. All Rights Reserved.

Thank you for using Virus=can Enterprise software. For a
description of product features, an overview of product system
requirements, and known issues for this release, see the
FEADME TAT file that comes included with the YirusScan
Enterprise software on the CD-REOM you received, orthatis
availlable as a separate download from the McAfee website.

hd
Zancel |

‘Wiew Readme |

Click Next



i
Q) NEthrk YOUR HETWORE. OUR BUSIMESS.

ASSOCIATES

Hetwork Aszociates End Uszer License Agreement

Lizehze expiry type: Select country where purchazed and uzed:
FPerpetual j ILlniteu:I States [default for uze in US] j
Metwork Assaciates Perpetual End User License Agreement ﬂ

MOTICE TO ALL USERS: CAREFLULLY READ THE FOLLOWING LEGAL

AGREEMENT ("AGREEMENT", FOR THE LICENSE OF SPECIFIED SOFTWARE
CSOFTWARE") PRODUCED BY NETWORK ASSOCIATES, INC. 'NETWORK
ASSOCIATES". BY CLICKING THE ACCERT BUTTOMN OR INSTALLING THE
SOFTWARE, ¥ OU (EITHER AM IMDIMIDUAL OR & SINGLE EMTITY) COMSENT TO BE
BOUMD BY AMD BECOME A PARTY TO THIS AGREEMENT. IF YOU DO MNOT AGREE
TOALL OF THE TERMS OF THIS AGREEMEMNT, CLICIK THE BUTTOMN THAT

IMDICATES THAT YOU DO NOT ACCEPT THE TERMS OF THIS AGREEMEMT AMD

Do MOT IMSTALL THE SOFTWARE. (IF APPLICABLE, YOU MAY RETURN THE
FRODUCT TO THE PLACE OF PURCHASE FOR AFLILL REFUND ) ;l

% | accept the terms in the license agreement

ok Cancel |

™ | do ot accept the terms in the license agreement

Step 11.4 — Change the License expiry type to: Perpetual

Step 11.5 — Click on I accept the terms in the license agreement

Click OK.



i'-‘% McAfee ¥irusScan Enterprise Setup |

VirusScan Select Setup Type
Enterprise 7.0 s ey

Installs a full set of features that includes YirusScan Consale,
On-fAccess Scanner, E-mail Scanner, On-Demand Scanner,
futolpdate, and Command Line Scanner, IF wou are installing ko a
server, Alerk Manager can also be installed.

i Cuskom

Installs a selected set of Features that includes a partial sek or all of
the Features included in a Typical installation. You can also use the
cuskom opkion ko install Alert: Manager o a waorkskation,

Install To
C:1Program FilesiMetwork Associates)virusScan),

, Browse, .. |
MCAfee Disk. Space < Back I Mext = I Zancel |

SECURITY

Click Next




i'-.% McAfee YirusScan Enterprise Setup

VirusScan
Enterprise 7.0

Ready to install

The wizard is ready to begin installation,

@
R

Click Cancel to exit the wizard.

lick Install to begin the installation,

IF wou want ko review or change wour installation settings, click Back.

2 McAfee —

SECURITY

Zancel |

Click Install

McAfee will now install the necessary drivers and files.




i'-‘% McAfee ¥irusScan Enterprise Setup x|

£ ‘;’iﬂm?cai}u McAfee YirusScan Enterprise setup
bl has completed successfully.

Allows wou to update wour virus definition (DAT) files by running
Autolpdate Mow, and scan your local drives by running On-Dremand
Scan. IF wou select both options, AutoUpdate runs first, then the
on-Demand scan immediately Fallaws,

[ Update Mow

Automatically checks for updates of virus defintion {0AT) Files andjor scan
enging and downloads any available updates,

[T Bun On-Demand Scan

Examines all fixed drives for infected files, Infections are looged in the
- OnDemandscanLog.txk file located in the directory Z:\Documents and
- Settingsiall Users\spplication DaktaiMebwaork AssociabesvirusScan),

Zancel |

; McAfee

SECURITY

Step 11.6 — Uncheck Update Now and Run On-Demand Scan

Click Finish

Step 11.7 — In the task bar, Right click on the McAfee Antivirus icon and choose VirusScan Console

=
Task Edit Wiew Tools Help
o] Y O | alalx e SdE

Task | Skatus | Lask result |
-@ On-Access Scan Enabled

i Autolpdate Weekly, 2:00 &M

|@E-mail Scan Enabled

@Scan Al Fixed Disks Mot scheduled

|'u'iru55can Consaole o




Step 11.8 — Right click on Auto Update and select Properties

B YirusScan AutoUpdate Properties - Autolpdate

-i_EE' Autollpdate tazkz update vinuz definitions [DAT files]
Ef and scan engines for all Metwark, Azzociates products

on this computer. Cancel |
Schedule... |Ipdate o | £ppl |
— Log file: Help |

ZALLUSERSPROFILE ZM\Application Data\Metwaork Azzo

Browse... |

— Bun options:

Enter the executable ta be run after pdate iz completed:

I Browse... |

™ Only Run after Successful Update

Step 11.9 — Click on the Schedule button



Schedule Settings d P

Tazk  Schedule |

—Schedule
Schedule Task: Start Time: r _
ud UTC Time
Weekl «| |02:004M = =
I = J I =1 e Local Time

Advanced... |
[l

W' Run missed task Delay mizzed tazk by IEI _l? minLtes
Schedule Tazk Weekly

¥ Enable randamization: |1 = hours ID ﬁ minutes

Exvery: |1 :|| week[slon | Mon I~ i

[~ Tue v Sat
[ wed [~ Sun
[~ Thu

] I Cancel Apply Help

Step 11.10 — Under the Schedule Tab you should schedule the Anti-Virus Update according to your needs.

Click Apply then OK.

(= ¥irus5can Console - DMZ-HARD =10l x|
Task Edit Wiew Tools Help
R EEECE S O EE
Task, | Skatus I Lask result |
On-Access Scan Enabled

% Autolipdate Weskly, 2:00 AM

«E-rnail Scan Disabled
@Scan All Fixed Disks Mok scheduled

|'-.-'iru55|:an Consale s




Step 12.0 - URL Scan Installation

Step 12.1 — Download and Double Click on the URLScan 2.5 executable.

UrlScan Installer Package =01 x|

Pleaze read the following license agreement. Press the PAGE DOWHN key
to 2ee the rest of the agreement.

EMD-USER LICEMSE AGREEMEMT FOR MICROSOFT il
SOFTWARE

IMPORTANT-READ CAREFULLY: This End-zer License

Agreement [[ELILA™] iz a legal aareement between you [gither an
individual ar a single entity] and Microzoft Corporation for the Microzaoft
zoftware that accompanies thiz ELA, which includes computer

goftware and may include azzociated media, printed matenials, “onling”

or electronic documentation, and Internet-bazed services

["Software™). An amendment or addendurn ta this ELILA may

accompany the Software. YO AGREE TO BE BOUMD BY THE
TERMS OF THIS ELILA BY INSTALLING, COPYING, OR

OTHERWISE USIMG THE PRODUCT. IF¥'0U DO MOT AGREE,

DO MNOT IMSTALL, COPY, OR IISE THE PRODUCT ; %01 MaY
RETURM IT TO ¥0UR FLACE OF PURCHASE [IF APPLICAELE) ;I

Do pou accept all of the kerms of the preceding License Agreement’? |f you
chooze Mo, [nstall will cloze. Toingtall pou must accept this agreement.

e Mo |

Step 12.2 — Click on Yes to accept the EULA.

URLScan will install and you will see the screen below when it is finished.

urlScan Installer x|

L.l
\]}) UrlScan has been successfully installed,

Click on OK to finish installation.

Step 13.0 — Disabling Protocols and Setting a Fixed IP for the Server.


http://microsoft.com/downloads/details.aspx?familyid=23d18937-dd7e-4613-9928-7f94ef1c902a&displaylang=en

Step 13.1 — Right click on My Network Places and choose Properties.

Step 13.2 — Right click on Local Area Connection and choose Properties. Choose the appropriate Local Area Connection and right click on
it and choose Properties.

e Uncheck Client for Microsoft Networks
e Uncheck File and Printer Sharing for Microsoft Networks

-4 Local Area Connection Propetties ed |

General I Authentication I Advanced I

Connect using:

I B8 AMD PCHMET Family PCl Ethernet Adapter

Thiz canhechion uzes the following items:
d % Client for Microzoft Mebworks

[ 8 netwark Laad Balancing
Il @, File and Printer Sharing for Microsoft Hetworks

= fInternet Protocol [TCPAR]
Install... | Wrinstall Properties
— Description

Transmigzion Control Protocalf|nteret Protocal. The default
vide area network protocol that provides communication
acrozz diverze interconnected netwarks.

[ Show icon in notification area when connected

k. | Cancel |

Step 13.3 — Select Internet Protocol (TCP/IP) and click on the Properties button.

Step 13.4 — Choose Use the Following IP Address and input your static IP address, Subnet Mask and Default Gateway.



Step 13.5 — Choose Use the following DNS Server Addresses and input your DNS Addresses. (NOTE: The addresses in the below
example are for illustration purposes only.)

Internet Protocol {TCP/IP) Properties el 4

General I

‘You can get IP settings assigned automatically if wour network supports
this capability, Otherwise, wou need ko ask yaur nebwark administrakar
for the appropriate IP settings,

" obkain an IP address automatically
¥ |Jze the Following IP address:

IF address: 192 168, 2 . 2
Subnet mask: | 255 . 255 . 255 . 0
Default gateway: [192 . 168 . 2 . 1

£ obkain DMS server address autamatically

* Use the Following DMS server addresses:

Preferred DNS server: I 10,10 .10, &5

alkernate DMS server: I

Advanced. .. |
Ik I Cancel |

Step 13.6 — Click on the Advanced button.
Under the DNS Tab

Step 13.7 — Uncheck Register this connection's address in DNS.



Advanced TCP/IP Settings |

IF Settings DMS |'-.-'-.-'INS | options |

DS server addresses, inorder of use:

40,10,10.5

|5
|2

add. .. Edit... Remoye

The Following three settings are applied to all connections with TCPJIP
enabled. For resolution of ungualified names:

* append primary and connection specific DMS suffixes
¥ append parent suffixes of the primary DMS suffix
" Append these DMS suffixes (in order):

| 5]
2

Addl.. | Edit. .. Remove |

DS suffix For this conneckion; I

[ Register this connection's addresses in DS
[ | Wse this conneckions GRS suffix in GRS registration

Ik I Cancel

Under the WINS Tab
Step 13.8 — Remove any WINS entries if they exist.
Step 13.9 — Uncheck Enable LMHOSTS lookup

Step 13.10 — Choose Disable NetBIOS over TCP/IP



Advanced TCP/IP Settings |

IP Settings | DN5  WINS |O|:|I:i|:|ns|

—WINS addresses, in arder of use:

| 5]
| ]

add. .. Edit, .. Remoye |

If LMHOSTS lookup is enabled, it applies to all connections for which
TCPJIF is enabled.

™ Enable LMHOSTS lackup Import LMHDETS. . . |

—MetBICS setking

" Defaulk:

Use MetBICS setking from the DHCP server, I static IP address
is used or the DHCP server does nok pravide MetBIOS sekting,
enable MetBIOS over TCP/IP,

" Enable MetBIOS over TCRIP
{* Disable MetBIOS over TCP|IR

Ik I Cancel

Under the Options Tab

Step 13.11 — Choose TCP/IP Filtering and click on the Properties button
Step 13.12 - Click on Enable TCP/IP Filtering (All adapters)

Step 13.13 — Change the Permit All radio buttons to Permit Only

Step 13.14 — Add ONLY the explicitly needed ports and protocols.

TCPPort | UDPPort | IPProtocol |




22 — SSH 161 — SNMP 6-TCP

80 -HTTP 162- SNMP Trap 8 — ICMP

443 —HTTPS 17 - UDP

TCP/IP Filtering g 1

v Enable TCP/IP Filkering (Al adapters):

" permit Al " Permit Al " Permit Al
— % Permit Only— — % Pemit Oply— — % Permit Only—

TCZP Ports LID'P Ports IP Protocals

2z 161 &

20 162 3

443 17
add. .. add... Add...
Remove | Remove | Remove |

(0] 4 I Cancel |

Click OK to apply the filters.

Click OK to return to Internet Protocol (TCP/IP) Properties

Click OK to finalize all configurations.

Click Close to close the Local Area Connection Properties.

Step 13.15 — Select Yes when prompted to reboot.

Step 14.0 — Turn on Remote Control

Step 14.1 — Right Click on My Computer > Properties > Remote

Step 14.2 — Under the Remote Desktop subsection, place a checkmark in the box.



System Properties d bl

General I Computer Mame I Hardware |
Advanced I Autamatic Updates Femote !

A= Select the ways that thiz computer can be uzed fram anather
location.

— Remote Azzsistance

Turn on Bemaote Aszistance and allow invitations to be zent from this
computer

Learn mare about Bemaote Assiztance.

Sdvanced... |

—Remote Dezklop
¥ Allow users to connect remately to thiz computer

Full computer name:
dmz-hard

Learn more about Bemote Deskiop,

Select Remate Users... |

0k, I Cancel | Spply |

Step 15.0 — Turn off Automatic Upgrades

Step 15.1 — Right Click on My Computer > Properties > Automatic Updates



System Properties ed B

General Computer Mame | Hardware
Advanced Automatic U pdates | Fiemate

YWindows can find the updates you need and deliver them
directly to your comprter.

[~ Keep my computer up bo date. With this zetting enabled, Windoves
|1pdate zoftware may be autormatically updated prior to applying
ary other updates.

Learn more about automatic updating

— Settings

[ atify me before downloading any updates and natify me again
before installing them o my computer

= [Download the updates autamaticaly and notify mewhen they are
ready o be imstalled

Automatically downlaad the updates, and install thenm arn the
schedule that || zpecify

Every day S ET R

Learn more about zcheduled inztalling

[eclined Updates

k. I Cancel Apply

Step 15.2 — Uncheck the Keep my computer up to date box.
Step 16.0 - Disable NetBIOS over TCP/IP

Step 16.1 — Click on Hardware Tab > Device Manager box.
Step 16.2 — Click on View > Show Hidden Devices

Step 16.3 — Click on View > Devices by Connection

Step 16.4 — Right click on NetBios over Tcpip > Properties > Disable



=0l x|

File  Action Yiew Help
NI I E.Y
i HTTP &

-~ IPSEC driver

\> ksecdd

----- @), Legacy Audio Drivers

----- E , Legacy Yideo Capture Devices
----- i§ Logical Disk Manager

----- @), Media Control Devices

----- i Wicracode Update Device

\> rinrndd
\> maunkrmgr

\> MDIS Swstem Driver
\> MWDIS Usermode IjO Protocol

\> MOProxy

\> Partition Manager

\> Parwdm

----- d Plug and Play Software Device Enumerator

- ROPCOD

\> Remate Access Auko Conneckion Driver

\> Remate Access IP ARF Driver

- » Remote Access NDIS TAPI Driver j

A pop up window should open that looks like this:

MetBios over Tcpip il

L ] "-n.‘ Dizabling this device will cause it ko skop Functioning. Da you really wank ko disable it?
[

Choose Yes



System Settings Change 5[

:/- ¥our hardware settings have changed, You must restart wour computer For these changes to take effect,
L]

Do you wank bo restark wour computer now?

Choose Yes when prompted to reboot.
Step 17.0 - SNMP Community String

Step 17.1 — Right Click on My Computer > Manage

Step 17.2 — Under Services and Applications, select Services




E Computer Management

=10l |

i

Extended }\ Skandard f

=] File  pction  Wiew window  Help == x|
= OEHE @] r s 1w
Q Computer Management (Local) Marne £ | Descripkion | Skakus | Skartup Twpe | Lag on As | :l
=- ﬁ% System Tools %Secnndary Logan Enables st..,  Started Aukomatic Local System
. @ Bvent Viewer %SEcurity Accounts ... The startu,,,  Starked Aukomatic Local System
% Shared Folders %SEWE[’ Supporks fil,.,  Starked Aukomatic Local Syskem
2 BT % hel Hardware Det... Providesn... Started  Automatic Lacal Systemn
%Smart Card Manages a... Manual Local Service
. %SNMP Sepvice Enables Si...  Started Aukornatic Local System
=g @ Storage : : :
-2 Removable Storage %SNMF‘ Trap Service Receives tr... Mariual Local Service
-_ ! Disk Defragmenter %Special Administrati...  Allows adm... Marual Local Swskem
=Y Disk Management %SSH Secure Shell 2 Started fukomatic Local Syskem
=N @# Services and Applications %System Ewent Motifi,., Monitors 5., Started Autornatic Local System
a Telephu:un':.f %Task Scheduler Enablesa ... Started Aukomatic Local Syskem
%TCF‘J‘IF‘ MetBIOS Hel.,. Provides s...  Started Autornatic Local Service
: %Telephnny Provides T... Manual Local System
g Indexing Jervice %Telnet Erables ar... Disabled Local Service
--P'J Internet Information Service %Terminal Services Allows user,..  Starked Marial Local System
%Terminal Services 5., Enables a ... Disabled Local System
%Themes Provides u... Disabled Local System
%Uninterruptible Pow.,., Manages a... Manual Local Service
%Uplnad Manager Manages ... Manual Local Syskem
i virtual Disk Service Provides s... flaral Local Swskem LI

Step 17.3 — Scroll Down and right click on SNMP Service and select Properties

Under the Security Tab

Step 17.4 — Ensure that Send authentication trap is selected.

Step 17.5 - Click Add




SNMP Service Configuration 7] x|
Community rights:

[READ ONLY =l

: Canzel
Cormrmunity M ame; —l

STROMG PASSWORD GOES HERE

Step 17.6 — Select READ ONLY for Community Rights

Step 17.7 — For Community Name (aka Community String), choose a strong password and type it into the box. This community string
(password) will need to be provided to anyone requesting SNMP access to this machine.

Step 17.8 — Choose Accept SNMP packets from these hosts.

Step 17.9 — Click Add and add the addresses from your SNMP network



SNMP Service Properties (Local Computer) 7| x|

Generall Log I:InI Fiecwer_l,ll Agent I Traps  Securty | Dependenciesl

v Send authertication trap

— Accepted community names

Rights |

STROMG_PASSWORD_GOES_HERE | READ OMLY

Add... Edit... Bemove

" Accept SHMP packets from any host
— % Accept SMMP packets from these hoste

your_shmp_hosts

sad. | Edt. |  Remove |

| ] 4 I Cancel | Apply

Step 17.10 — Click on the Traps Tab and in the Community Name white-space, type: public

Step 17.11 - Click on the Add button and add the addresses of your trap destinations



SNMP Service Properties (Local Computer) 7| x|

Generall Log I:InI Fiecwer_l,ll dgent  Traps |Se-:urity| Dependenciesl

The SMMFP Service provides netwaork management aver TCPP
and PSP protocolz. If raps are required, one or more
community names muzst be specified. Trap destinatiohz may be
host names, IP addrezses or [P addresses.

— Community name
rublic =] Aadiafist |

Remowve from list |

Trap destinations:

Add... Edit... R emove

| ] 4 I Cancel Apply

Step 17.12 — Click Apply then click OK to exit.

Step 17.13 — Close the Computer Management window.

Step 18.0 — Setup the IPSec Policy
Step 18.1 — Download the 1PSec Policy File.
Step 18.2 — Review the file and remove any IPSec filters that you do not explicitly need.

By default, the following services are configured in the IPSec Policy file:


http://www.shebeen.com/w2k3/ipsec-policy.inf

IIS 6.0 DMZ Server IPSec Network Traffic Map

Service |Protocol | Source |Destination| Source |[Destination| Action Mirror
Port Port Address | Address

SSH TCP ANY 22 ANY ME ALLOW YES
DNS TCP ANY 53 ANY ME ALLOW YES
DNS UDP ANY 53 ANY ME ALLOW YES
HTTP TCP ANY 80 ANY ME ALLOW YES
SNMP UDP ANY 161 ANY ME ALLOW YES
SNMP

TRAP UDP ANY 162 ME ANY ALLOW YES
HTTPS TCP ANY 443 ANY ME ALLOW YES
SYSLOG UDP ANY 514 ANY ME ALLOW YES
ICMP ICMP ANY ANY ANY ME ALLOW YES
All Other

Inbound ANY ANY ANY ANY ME BLOCK YES
Traffic

Step 18.3 — You can copy and paste the lines from the file into a command shell window to install the policy.
Step 19.0 - Configure Terminal Services

Step 19.1 — Go to Start > Programs > Administrative Tools > Terminal Services Configuration (TSC).
Step 19.2 — Over in the right panel, right mouse click on RDP-Tcp and choose Properties.

Under the General Tab:

Step 19.3 — Change the Encryption Level to High.



RDP-Tcp Properties d bl

Fiemate Control I Client Settings I Hetwork Adapter I Permizzions
General I Logon Settingz I Seszionz I E nvironment

oy ROP-Tep

Type: bicrozoft ROP 5.2

Transport; tcp

Camment:

— Encryption

Encroption level: High j

&l data zent between the client and the zerver iz protected by
encryption based on the server's masmum key strength. Clients
that do not zupport thiz level of encryption cannot conneck.

[ Use standard ‘Windows authentication

()4 I Cancel Apply

Under the Sessions Tab
Step 19.4 — Check the first Override User Settings, then choose:

e End a Disconnected Session: 3 Hours
e Active Session Limit: 1 Day
e |dle Session Limit: 30 Minutes

Step 19.5 — Check the second Override User Settings and choose: Disconnect from Session.



RDP-Tcp Properties

Fiemate Control I Client Settings l Hetwork Adapter I Permizzions

General I Logon Settingz Session:

I1ze thiz tab ko zet Teminal Services timeout and reconnection settings.

E nvironment

2l xi

W ‘Owernide user settings

End a disconnected session; |3 hours j
Active session limit: |1 day j
|dle zezzian limit; ISEI rintes j

v Oweride user zettings
When zezzian imit iz reached or connection 1z braken:

* Dizconnect from session

" End zession

™| Dweride user settings
Allow reconnection:

£ From any client

€ From previous client

k. I Cancel

apply

Under the Remote Control Tab

Step 19.6 — Choose Do not allow remote control




RDP-Tcp Properties d bl

General | Logon Settings I Sezzionz I E rvironment
Femate Control | Client Settings I Metwork Adapter I Permissions

Y'ou can use remote control o remotely control or obzerve a user's
ZESEION,

" Use remate contral with default uzer settings

+ Do nat allow remote controb

" Use remate contral with the following settings:

T o reguire the uzer's permizzion to control or obzerve the session,
zelect the following check box:

I¥| Bequire user's permizsion

[Lewel af cantral
% Yiew the session

= |nteract with the sezsion

()4 I Cancel Apply

Under the Client Settings Tab:

e Uncheck Use Connection Settings From User Settings
e Uncheck Connect Client Printers at Logon and Default to Main Client Printer

Under the Disable subsection:

Step 19.7 — Check all boxes except Clipboard Mapping.



RDP-Tcp Properties d bl

General I Logon Settings | Sezzionz I E rvironment
Femate Contral Client Settings I Metwork Adapter I Permissions
— Connection

[ Uze connection settings from user settings
¥ Connect client dives at logan
[T Connect client printers at logon

[ Default to main client printer

v Limit taximum Color Depth

[ 16 it =

Dizable the following:

¥ Diive mapping [V COM port mapping

[V ‘Windows printer mapping |

¥ LPT port mapping ¥ Awudio mapping

()4 I Cancel Apply

Under the Network Adapter Tab:

Step 19.8 — Click on the Maximum Connections radio button and ensure the number is set to 2.



RDP-Tcp Properties d bl

General I Logon Settings | Sezzionz | E rvironment
Femate Contral I Client Settings Metwork Adapter | Permissions

The following network. adapters are compatible with the zelected transport
twpe. Select the netwark, adapter you want to Lze.

Metwork adapter:

with this protocol

configured

Al network, adaphers

£ Urlimited cormections

¥ b grimum connections: 2 =

Thiz zerver iz configured in the default Remate Desktop mode for
remaote adminiztration, which allows a mawximum of bwo simultaneous

remote connections.

()4 I Cancel Apply

Step 19.9 — Click Apply and then close the window.

Step 20.0 - Set up Terminal Services to run over SSH
Step 20.1 — Open the SSH Secure Shell Client

Step 20.2 — Select the folder named Profiles > Add Profile

Step 20.3 — Give the Profile a Name and then click the Add to Profiles button.



Add Profile x|

ISewer_N ame_Here Add to Profiles

Step 20.4 — Select Profiles folder again and select Edit Profile.

Step 20.5 - In the left window, choose the Server profile that you wish to edit.

Under the Connection Tab:

e Enter Hostname of your server.
e Enter User name that you are authenticating with.

NOTE: This User Name will have to be changed to match that of the name in Step 23.2



Profies x|

e E Quick Connect Colors I Tunneling I File Transter I Favarite Folders

E||:I Frafiles Connection | Cipher List | Authentication | Keyboard
- Web Server_MName

Configure pratocol zettings far the connection. Mew zettings will take effect
upon next login.

Specify * az the hozt name or the uzer name to be prompted far the
information when the profile iz chozen for connecting.

Host name: IWEI:S erver_Mame_Goes_Here
Uszer name: |.-'1'-.dmin_N ame_Goes_Here
Poit nurnber: |22

122 ~]

Encroption algaorithim; I <Defaulty

=
AL algorithnn: |<Default> j
LCompressian: I <Moner j

=

Terminal answerback: IVH 0o

[ Caonnect through firewal

[ Bequest tunnels only [dizable terminal]

(] Cancel

Under the Authentication Tab:

Step 20.6 — Under Authentication methods, choose Password. Move Password to the TOP of the list using the black arrows.



po ﬂ Quick Connect
=] Profiles
e, ‘Web_Server_Mame

Colors I Tunneling I File Transter I Favarite Folders
Connection | Cipher List Authentication | Kevboard

Configure uzer authentication methods and their prefered arder.

Authentication methods: HE A S

Public Key
Kevboard Interactive

Configure public-key authentication methodz and their preferred order.

Public-key authentication methods: R G S

53H Accession Certificates
55H Accession Kevs

PKCS #11 Certificates
PECS #11 Keys

ser Cettificates

User Keys

— Authentication Agent fanwarding

Configure agent formarding for S5H2 and SSH1 connections. This
feature iz available with 55H Accezsion, which provides single
zign-on to gervers that allow public-key authentication.

¥ Enable for 55H2 connections

[~ Enable 55H1 agent forwarding for S5H2 connections
[ Enable for 55H1 connections

X

(] Cancel

Under the Tunneling Tab:

Step 20.7 — Ensure that the Outgoing frame is selected and click on the Add button.



CETTE x|

& Quick Connect Cormection | Cipher List I Athentication I k.epboard I

£+-{ Profles Colars Tunelng | Fie Tramter | Favorte Fodes
& Server_Mame_Here

Configure secure outgoing tunnels that are intiated from the local computer
to the server. Communication will be zecured bebween the local compuker
and the server, but ingecure beyond the zerver.

The zettingz will take effect upan hext lagin.

Outgaing | Inn::n:nmingl

Mame | Ligten Part | Dest Host | Dest Port | Allane

1 | i

Add.. Edt. | EY—

=17 tunneling

Enable zecure tunneling for =17 graphic connections. An & server
hag to be alzo running in pazsive mode on the local computer,

[ Turnel ¥11 connections

k. Cancel

Step 20.8 - When the Add New Outgoing Tunnel prompt comes up fill in the following information:

e Display Name: Terminal Services
e Listen Port: 3389
e Destination Port: 3389



Add New Outgoing Tunnel

Dizplay Hame: ITerminaI Service

Tupe: I TCP - I
Lizten Port; IESEEI e

v sllow Local Connections Only

Cancel

Destination Host; IIn:n::thn:nst

Destination Port; |3399 Hep

i

Click OK to complete the Profile Setup.
Step 20.9 — Open the Profiles folder and choose the profile that you just created to connect to your server.
After secure key negotiation, the warning box below will pop up.

Click OK to continue.

x
BT | WARNING!
READ THIS BEFORE ATTEMPTIMNG TO LOGOM

Thiz Syztem iz for the uze of authorized wzers only. Individualz uging thiz computer without authaority, or in excess of their
authority, are subject to having all of their activities on this system maonitored and recorded by systemn personnel. [n the
courze of monitonng individuals improperly using thiz zpztem, or in the courze of spstem maintenance, the activities of
authorized users may alzo be monitored. Anyone using thiz zpztem expreszly consents to such monitaring and is advised
that if zuch monitoring reveals pozsible criminal activity, spstem personnel may provide the evidence of such monitoring
to law enfarcemnent officialz.

The Password prompt box will pop up.
Step 20.10 — Enter the correct password and click OK to continue.

Step 20.11 — After you have successfully authenticated and logged in, open your Terminal Services Client and connect to Localhost.



% Remote Desktop Connection -10] x|

2 Desktop
ction

Compuiter: II-:u:thu:ust j

Connect I Cancel Help | Options >

You will now be running Terminal Services over one of the most security-scrutinized protocols ever. This is the only InfoSec approved remote
management for MS 2003 Servers in the DMZ.

Step 21.0 - Applying the High Security Web Server .inf file

Step 21.1 — Download the www-w2k3-dmz.inf file to your desktop.

Step 21.2 - Go to Start > Run > MMC

Step 21.3 — Click on File > Add/Remove Snap In


http:/www.shebeen.com/w2k3/www-w2k3-dmz.inf

Add/Remove Snap-in 7] x|
Standalone | E:-ctensil:unsl
I1ze thiz page to add or remove a standalone Snap-in from the conzole.
Snap-ins added to: |% B -
— Dezcription
Add.. Eemove Aot |
ITI Cancel |

Step 21.4 — Click on the Add button and scroll down to Security Configuration and Analysis



Add Standalone Snap-in 7] x|

Awallable Standalone Snap-ins:

Shap-in | Yendor |i|
@ Link to'Web dddress Microzoft Corparation

ﬁ Local Uzers and Groups icrozoft Corporation

ﬁ Performance Logs and Alertz bdicrozoft Corporation

E Femaote Deskiops bicrozoft Corporation

(_‘: Removable Storage bManagement ticrozoft Corporation
Resulkant Set af Palicy ticrozoft Corparation

E Routing and Remote Access ticrozoft Corporation

. Security Configuration and Analysiz ticrozoft Corporation

@ Securty Templates icrazaft Carparation

% Services Microzoft Corporation LI
— Dezcription

Security Configuration and Analysis iz an MMC shap-in that provides
gecurity configuration and analyziz for Windows computers using security
template files.

Add Claze

Step 21.5 — Click the Add button then Click the Close button
Step 21.6 — Click the OK button on the Add/Remove Snap In window to continue.
Step 21.7 — In the Left Pane, right click on Security Configuration and Analysis and choose Open Database

Step 21.8 — Navigate to the C:\WINDOWS\security\Database directory and give your database a name in the form
LOCALSERVER_SECPOL_LGPO and click Open



2| x|
Laak i I&} D atabaze j ) il B ERE

by Documents

wr
@
by Computer

File name: [waxaomz =
Filez af type: ISecurit_l,l Database Files [*.2db) j Cancel |

This will open another pop-up box asking for the template file.



Look: ir: I@' Desktop j =

:—} -k 3-dmz. inf

4] [+

File name: |2k 3-dmz.inf Open |
Files of bype: ISecurit_l,l Template [.inf] j Cancel |

[ Clear thiz database before importing

A

Step 21.9 — Navigate to your Desktop and type in the name of the .inf file that you previously downloaded.
Step 21.10 — Click Open to continue.
Step 21.11 — Right click on Security Configuration and Analysis and choose Configure computer now.

Step 21.12 — This will pop up a box asking where you wish to write the log file. You can choose the default and click ok.

Configure System 2 x|

Error log file path:
Istratnr"aM_l,l DocumentzhSecunty Logz DS 2K 3 og Browse ... |

] I Cancel |

The computer will now apply the INF file



Configuring Computer Security

Configuring:

¥ Uszer Rights Assignment ™ System Services
+ Restricted Groups Security Policy

¥ Fegisty

+  File Sypstem

Step 21.13 — When the configuration is done, you can close the Consolel window.

The .inf file will make the following changes. (add changes link here)

Step 22.0 - 11S 6.0 Configuration

Step 22.1 — Go to Start > Programs > Administrative Tools > Internet Information Service (11S) Manager.

Step 22.2 — Choose the Default Web Site and Stop it by clicking on the black square on the taskbar.



W Internet Information Services (I15) Manager O] =|

¥9 Fle  Action  Wiew Window  Help — |7 =]
= BHE XEDR @2 2]y mn
lif. Internet Information Services | Mame [Stop item |Path [ Status

El---i_! W2K3-HARD (local compute | = jisstart htm
B ) Application Pools L
=) Weh Sites
g Defaulk Web Site

| web Service Extension:

|=| pagerror.gif

q | o|al | 2|

Step 22.3 — Right click on the PC Icon above and choose All Tasks > Backup/Restore Configuration.



Configuration Backup/Restore 5[

—Previous backups
Backups:
Location | Wersion | Date/Time |
=| Initial Backup - created aoktom... 1 71Z2{2003 1:08: 33 PM &
=| aukomatic Backup TIZZIZ003 1:10:24 PM
=| aukomatic Backup TI232003 6:25:22 AM
=| aukomatic Backup TI232003 6:32:10 AM
=| aukomatic Backup 71232003 7:02:02 AM ©
=| aukomatic Backup 12312003 7:33:50 AM
=| aukomatic Backup 12312003 7:42:07 AM ;I
| Create Backup,., ! Festore | Delete |

Close Help |

Step 22.4 — Select Create Backup, name your backup file and click OK to complete the task.

Configuration Backup x|

Configuration backup name:

I Pre-configuration backup

™ Encrypt backup using password

Passwiord; I

onfirm password; I

(0] 4 I Cancel

Once completed, you should see the file that you just created in the list.



Configuration Backup/Restore 5[

—Previous backups
Backups:

Location | Wersion | Date/Time |

=| Initial Backup - created aoktom... 1 10)7/2003 9:22:35 AM &

=| aukomatic Backup 10)9/2003 10:50: 26 AM

=| aukomatic Backup 10/9)2003 10:53:30 &M |

=| aukomatic Backup 10092003 11:13:50 AM

=| aukomatic Backup 10092003 11:23:35 AM

=| Automatic Backup 10092003 11:31:24 AM ;I
Creake Backup... | Restore | Delete |

Close I Help |

Click Close to complete the task and continue.
Step 22.5 — Editing the Master Properties for Web Sites

Right click on the Folder labeled Web Sites and choose Properties.



Web Sites Properties 21x|

Directory Security I HTTP Headers I Cuskom Errars I Service
Web Site I Performance I IS4P1I Filkers I Home Direckary I Documenks

—Web site identification

Description: I

IF address: I{.ﬁ.ll Unassigned) j Advanced, ., |
TR porks I S5l park: I

— Connections

Connection Limeout: I seconds

¥ Enable HTTP Keep-alives

—Iv Enable logging

Ackive log Format:

I'-.-'-.-'SC Extended Log File Format j Properties. .. |

Ik I Cancel Al Help

Step 22.6 — Choose Web Site > Enable Logging > Properties:
Step 22.7 — Under New Log Schedule, select the radio button labeled When file size reaches: and change the value to 50.

Step 22.8 — Click on the Advanced Tab, scroll to the bottom of the list and add checks for Cookie and Referer.



Logging Properties

General Advanced |

Extended logoing options:

- v Method ( cs-method )

- [ URI Stern | cs-uri-stem )

- [w] URI Query | cs-uri-query )

- [w] Prokocol Skatus ( sc-stakus )

- [w] Prokocol Substatus  sc-subskatus )
- v WIN32 Skatus { sc-win32-stakus )
- [] Bykes Sent [ sc-bytes )

- [] Bwkes Received ( cs-bykes )

- [] Time Taken ( time-taken )

- [] Prokocol Yersion { cs-version )

- ] Host { cs-host )

- [w] User Agent { csillser-fgent) )

- v Referer [ cs(Referer) )

Cookie ( cs(Cookig) )

[4]

0, I Zancel apply

Help

Click OK

Under the Home Directory Tab

Step 22.9 — Under the Application Settings subsection, choose Configuration.

Step 22.10 - Remove all Application Extensions, as referenced below:

NOTE: Remove them all and add back in as needed!

Extension Filetype
.asa ASP Files to declare objects with session or application scope
.asp Active Server Pages
.cdx Scripts to create Channel Definition files
.cer Scripts for digital certificates
idc Internet Database Connection
.shtm Server Side Includes




.shtml Server Side Includes

.stm Server Side Includes
x|

Mappings IOptiu:uns I Cebugging I Cache Options I

¥ Cache ISAPT extensions:

—Application extensions

Extens... | Executable Path | Yerbs -
853 CWIRDOW S system3Zinetsrvlasp dl - GET,HEA. .
asp CWINDOWSsystem3Zinetstvlasp.dl - GET,HEA.,
Lo C INDOW S, syskem32linetsrviasp.dll - GET,HEA, —
(CEF CHWIRDOWS syvstem32inetstvlasp.dl - GET,HEA..
Jidc CWIRDOW S system3Zinetstvihttp,,,  GET,POST -
4| | F
Add... | Edit... Remoyve |

Wildcard application maps {order of implementation):

Insert... |
Edit . |
Eemove |

Mave g | [Mave Do |

(4 I Cancel | Help

Step 22.11 - For any extensions that are re-added, consider limiting the HTTP verbs the extension will accept. Instead of using all the verbs
(DELETE, GET, HEAD, POST and TRACE), use only GET for Static Web Pages and POST if you have forms on your site. This is in
accordance with the least privilege principal.

Step 22.12 — Click OK to get out of edit mode.
Click OK to close the Website Properties window.

Step 22.13 — Highlight the Web Sites Folder, right mouse click and select New > Web Site.



Webh Site Creation Wizard X|

Welcome to the Web Site

% Creation Wizard

Thiz wizard helps you create a new Web zsite an thiz
computer.

To continue, click Hext.

¢ Back

Cancel |

Click Next to continue

Step 22.14 - Give your Web Site a Description



Weh Site Creation Wizard

Wweb Site Desciption
Dezcribe the \wWeb zite to help administrators identify it

Tupe a description of the Web site.

Deszcrption:
our_|15_Website_Mame_Here

¢ Back I MHewt > I Cancel

Click Next to continue

Step 22.15 — Add the IP address and Port Number (the defaults are usually appropriate).



Weh Site Creation Wizard

IP Addrezs and Port Settings
Specify an IP addrezs, port zetting, and host header for the new 'Web zite.

Enter the [P address to use for thiz Web site;
[&ll Unazzigned] j

TCF port this *eb site should use [Default: S0);
0

!

Huost header faor this *eb site [Default: Mone]:

For more information, read the (15 product documentation.

¢ Back I MHewt > I Cancel

Click Next to continue

Step 22.16 — Choose a drive that is NOT your system partition for the path of your new web site. You will have to click on Browse, select the
drive and create a new directory.



Web Sike Creation Wizard

Y My Computer

ﬂ, 314 Flappy (A1

S Local Disk ()

= S Mew Volume (D
st wehsite

Yiware Tools ()

| Make Mew Folder I | Ok I Cancel

v

Step 22.17 - Click OK to select the newly created directory.



Weh Site Creation Wizard

Wweb Site Home Directory
The home directary iz the root of pour Web content subdirectonies.

Enrter the path to pour home directory.

Fath:

ID:'\test_weI:usite Browse. .. |

v allow anonymous access to this Web site

¢ Back I MHewt > I Cancel

Click Next to continue

Step 22.18 — Choose the minimum set of permissions here for your web site by un-checking the Run scripts (such as ASP) box.



Weh Site Creation Wizard

Web Site Access Permissions
Set the access permizzions for thiz Web site.

Bllow the following permizsions:

v Head

[~ Run scripts [zuch az A5P)

[T Execute [such az 154P| applications or CG)
[ white

[T Browse

To complete the wizard, click Hext .

¢ Back I MHewt > I Cancel

Click Next to continue
Step 22.19 - Click Finish to complete the Web Site Creation Wizard

Step 22.20 — (Optional) Microsoft recommends configuring a separate directory for each file type so that you can easily set ACLs. Best
Practice:

This is a good idea if you have the ability to do so. For example, if your website base directory was E:\test_website then you would setup your
web site such as:

E:\test_website\static (.htm, .html)

E:\test_website\include (.inc)

E:\test_website\script (.asp, .pl, .cgi)

E:\test_website\bin (.dll) - VisualStudio likes bin when building projects.
E:\test_website\images (.gif, .jpg, .jpeg)

Step 22.21 — Disable the Default Web Site. It is better to disable the default web site rather than remove it as it may come in handy later.



Step 22.22 - Right click on the Default Web Site. Select Properties > Directory Security > Authentication and Access Control > Edit

Step 22.23 — Uncheck all the boxes.

Authentication Methods x|

1 Enable anonymous access

IJse the Following Windows user accounk For anonymous access:

Llser name: I ILSR M2k 3-HARD Browse. .. |

Password; I [TTXITIITT]

—Authenticated access

Far the Following authentication methods, user name and passward
are required when:

- anonymous access is disabled, or

- access is restricked using MTFS access control lisks

[ Integrated Windows authentication;

™ Digest authentication For Windows domain servers
[ EBasic authertication (password is senk in clear kext)
[~ MET Passport authentication

Default domain: I Seleck, .,

i

Realr | Seleck. ..

| Ik I Zancel | Help |

You will get a warning screen as shown:

I15 Manager 5'

» | The authentication options you have selected will result in all access being denied,
\"/' Are wou sure woll want ko dao this?




Step 22.24 — Select Yes
Step 22.25 - Click OK to complete the task.

Step 22.26 — Check for and remove all 11S Sample directories

e Admin Scripts C:\InetPub\AdminScripts
e 1ISHelp C:\Windows\help\iisHelp
e 1ISadmpwd C:\Windows\System32\inetsrv\iisadmpwd

Remove Internet Printing
Step 22.27 — Delete the printer's virtual directory at C:\Windows\web\printers
Back up the Metabase again

Step 22.28 — Go to Start > Programs > Administrative Tools > Internet Information Services (11S) Manager



[ Internet Information Services (I15) Manager

=10 x|

1 | ol

¥9 Fle  Action  Wiew Window  Help — |7 =]
&= AW ERE 2 8.
lf. Internet Information Services | Mame | Skakus
e 530 SOERERRTNUEIN | appiication Pools
__Iweh sites Service is running
__I'web Service Extensions
| H

Step 22.29 — Right click on the computer name, select All Tasks > Backup/Restore Configuration



Configuration Backup/Restore

—Previous backups
Backups:
Location | Wersion | Date/Time |
=| Initial Backup - created aoktom... 1 71Z2{2003 1:08: 33 PM &
=| Backup Configuration File 1] TI2312003 10:39:15 AM
=| aukomatic Backup 12312003 10:43:35 AM
=| aukomatic Backup 7123/2003 10:43:37 aM |
=| aukomatic Backup TI2312003 10:45:32 AM
=| aukomatic Backup TI2312003 1005220 AM
=| Automatic Backup FI23)2003 11:00:27 AM ;I
| Create Backup,., ! Festore | Delete |

Close Help |

Step 22.30 — Select Create Backup

Configuration Backup x|

Configuration backup name:

I Post-Configuration Backup

™ Encrypt backup using password

Passwiord; I

onfirm password; I

(0] 4 I Cancel |

Step 22.31 — Name your backup file and click OK to continue.




Configuration Backup/Restore 5[

—Previous backups

Backups:
Location | Wersion | Date/Time |
é Initial Backup - created aukom,., 1 10/7/2003 9:22:35 AM =
é Pre-configuration Backup 1] 1092003 3:24:37 PM
B Post-Configuration backup 0 109/2003 3:
é Aukamatic Backup 10)9/2003 1050126 AM  —
é Aukamatic Backup 10)9/2003 10:53:30 AM
é Aukamatic Backup 10092003 11:13:50 AM
é Aukamatic Backup 10092003 11:23:35 AM ;I
Restore | Delete |
Close Help |

You should see your original backup file and your backup after the configuration steps above.
Step 22.32 - Click Close to complete the task.

Step 22.33 - Start > Run > gpedit.msc

Under Computer Configuration > Administrative Templates > Printers

Step 22.34 — Change Web Based Printing to disabled.



'iii Group Policy Object Editor -0l x|

File  Action Miew Help
Al A=Y

_=:_j Local Computer Policy Setking State |

El@ Computer Configuration @ Allows printers to be published Mot configured

(] Software Settings @ Allows pruning of published printers Mot configured

I:I Winc.lu.ws 5|.3ttings @ Aukomatically publish new prinkers in Active Direckary Mot configured

Em--Em;::i:zﬂzec-;::zl:;is @ Check, published state Mok configured

[:l System @ Computer location Mok configured

|:| Netwark @ Custam support URL in the Printers Folder's left pane Mot configured

a Printers @ Direckary pruning inketwal Mot configured

I':'Iﬁ User ConFiguration @ Directary pruning priority Mok configured

[:l Software Settings @ Directary pruning retry Mok configured

-] Windows Settings @ Disallows installation of prinkers using kernel-mode drivers Mot configured

[:| Administrative Templates @ Log directory pruning retry events Mok configured

@ Pre-populate printer search location bext Mok configured

Printer browsing Mok configured

@ Prune printers that are not automatically republished Mot configured

@ Allow Print Spoaler ko accept client connections Mok configured

Disabled
Extended ;\ Standard ,f"

Step 22.35 — Under the Network > Network Configurations folder, change the value for Prohibit use of Internet Connection Sharing on
your DNS Domain Network to enabled by right clicking and choosing Enable.



'ifi Group Policy Dhject Editor -0l x|

File | Action  Wiew Help

& | anaE| 2

§ Local Computer Policy Setting | ctate |
E'@ Computer Configuration - “IProhibit use of Internet Connection Sharing on your NS damain ... Enabled
D Software Settings @ Prohibit use of Internet Connection Firewall on vour DNS domain ... Mok configured
I:I indaus Settings @ Prohibit installation and confiquration of Mebwark Bridge on vour D,.. Mok configured

E”:I F'.I:Imln!stratwe U @ IEEE 802, 1x Certificate Authority For Machine Authentication Mot configured
[:l wWindows Components

[:l Swyskemn

B (2 Metwork

- DNS Client

-7 Offline Files

-3 Mebwaork Connections
- oS Packet Scheduler

I:l Printers

EI@ User Configuration

I:l Software Settings
D Windows Settings
I:l Adrinistrative Templates

Extended 3 Standard £

Step 23.0 — Rename and change the password to the IUSR_<machinename> account.
Step 23.1 — Right click on My Computer > Manage

Step 23.2 — Double click on Local Users and Groups and choose the Users folder. In the right pane, choose the Administrator account.
Right click and rename this account using the syntax <machinename>_adm

Example: the name of the machine is DMZ-Hard, so the newly renamed Administrator account would be DMZ-Hard_adm



O Computer Management O] x|

=] File  pction  Wiew window  Help =]
& = | | X NE
Q Compuker Management {Local) Mare | Full Marne | Description
Elﬁ% System T':":'!s %disabled_guest Built-in accounk For gue:
@ SOV ILISR_DI"-’IZ-HP.RD Inkernet Guest Account Built-in account For ano
% fharFS Fnldersd c 3 1 am_DMZ-HARD Launch IT5 Process Accaunt  Built-in account Far Inke
B : gau == and faroups Eﬂbscure_name_here Inkernet Guesk Account Built-in account For anoi
=1 .
£ croups iDMZ-Hard _adrn Built-in account For adr
- & Performance Logs and Alerts QSUPPORT_SBB%EaD CM=Microsoft Corporation...  This is & vendor's acoou
= Device Manager
EI@ Storage
[+]- Removable Storage
& Disk Defragmenter
i Disk. Managernent
EEI--@ Services and Applications
4 (I3 KT | i

Step 23.3 — Choose the IUSR_<machinename> account.

Step 23.3 — Right click and rename this account to an obscure name. (Remember this new name, you will need it later in step 24.4). Note
that, even though you rename the IUSR_<machinename> account, it will show up again in the list of local users. You should right click on
the regenerated IUSR account, and disable it. It is safe to ignore it after performing this step.

Step 23.4 — Refer back to Step 20.5 and change the Username to match the name in Step 23.2.



~ioixd
=] File  pction  Wiew window  Help =]
P | X e

Q Compuker Management {Local) Marme

| Full Marne | Descripkian

Elﬁ Swstem Toals
@ Event Yiewer
% Shared Folders

% disabled_guest

3 1M _DMZ-HARD

[+

& Disk Defragmenter
i Disk. Managernent
EI--@ ervices and Applications
=5 Telephony
% Services
- wMI Control
58 Indexing Service
f‘g Internet Information Service

1 | 0

cure_Mame_Here Internet Guest Account

[=-#7 Local Users and Groups @ru:u:ut
% aneis % SUPPORT 33894530

Built-in account For guest acc
Built-in account For anonymol

Launch II5 Process Account Builk-in account for Internet I
Built-in account for adminiske

CH=Microsoft Carporation..,  This is a vendaor's account For

Step 23.5 — Right click on this newly renamed account and choose Set Password.

You will get a Warning Box like the one below.




Set Password for Obscure_Name_Here x|

Fezetting this paszword might cauze imeverzsible logz of information for this user account,
Far zecurity reazonz, Windows protects certain infarmatian by making it imposzible ko
acceszs if the user's paszwaord is rezet.

Thiz data logz will occur the nest time the uzer logs off.

ou should uze this cammand only if a user haz fargotten his ar her pazsword and does
not have a pazzword rezet dizk. If thiz uzer has created a pazsword rezet digk, then he ar
zhe should uze that digk to set the password.

If the uzer knows the passward and wantz ta change it, ke ar zhe should lag in, then
prezz CTRL+ALT+DELETE and click Change Pazswaord.

For additional information, click Help.

Cancel Help

Step 23.6 — Click Proceed and select and set a strong password for this account. (Remember this password, you will need it later).

Step 23.7 — You can now close the Computer Management window.

Step 24.0 - NTFS Permissions
Step 24.1 — Double click on My Computer
Step 24.2 — Right click on the C:\ drive and choose Properties > Security

Step 24.3 — Click the Add Button



Select User or Group

Select thiz object wpe:

ILlser, Group, or Built-in zecurity principal Object Types...

Erom thiz location:
IDMZTEST Locations...

Enter the object name to select [examples]:

vour_renamed_|ISR_acocount_goes_here Check Mames

FEE

Advanced... | ]S | Cancel |

4

Step 24.4 — In the white space, type in your renamed IUSR account from Step 23.3 and click OK



New Yolume {E:) Properties 7] x|

General | Toolz I Hardware I Sharing
Security | Duota I wieh Sharing
Mame | Add..

€7 sdmiristrators (DMZTES T\Administiators]
€7 CREATOR OWNER Remave |
#4115 _Guest [DMZTESTAIS_Guest)

€7 SvSTEM
€7 Users [DMZTES T Users)

Permizsions: Al Deny
Full Cortral O
Fodify O
Fead & Execute O
Lizt Folder Contents O
Fead O
Wiite O

Advanced... |
] I Cancel Apply

Step 24.5 - Highlight this newly added user and choose Deny Full Control and click OK.
Step 24.6 — Repeat these steps for all other volumes.

Step 24.7 — To Apply the proper NTFS permissions to the individual directories, Right click on the C:\Windows Directory and select
Properties

Step 24.8 — Click the Advanced button

Step 24.9 — Click the Add button and in the white space, type in the name of your renamed IUSR account from Step 23.3.



Select User or Group

Select thiz object wpe:

ILlser, Group, or Built-in zecurity principal Object Types...

Erom thiz location:
IDMZTEST Locations...

Enter the object name to select [examples]:

vour_renamed_|ISR_acocount_goes_here Check Mames

Advanced... | ] 4 | Cancel

FEE

Step 24.10 — Under Apply onto: select This folder only
Step 24.11 - Give permissions to:

Travers Folder / Execute File
List Folder/ Read Data

Read Attributes

Read Extended Attributes
Read Permissions




Permission Entry for WINDOWS 7] x|

Object |

Marne: Iuest.-‘l'-.-:cnunt [DRZTEST \drnztestuser) Change... |

Apply anta: IThis folder orly j

Permizsions: Sl Deny

Full Control (=
Traverse Folder / Execute File
Lizt Folder / Fead Data

Read Attibutes

Fead Extended Attibutes
Create Files / Write Data
Create Folderz / Append D ata
Wit Attributes

Wihite Extended Attibutes
Delete Subfolders and Files
Delete

O
O
O
O
O
O
D-.

Read Pemizsions

[l PR I j
r Spplythese permizsions to objects andar Clear Al |

cohtaimers within this container anly

] I Cancel |

1000000000000

Step 24.12 - Click OK and your resulting screen should resemble the one below.



Advanced Security Settings for WINDOWS 7] x|

Fermniszions |.-“-‘-.u|:|iting| I:Iwnerl Effective Permissinnsl

T o view mare information about special permizsiong, select a permizzion entry, and then click Edit.

Permizzion entries:

Permizzian

Thiz fl:ull:lr,sul:ufl:ull:lers...

2 |nternet [uest 5 1
Dery |nternet Guest Account...  Full Control

Allone Adrmirigtrators [DMETE... Full Control Thiz folder, subfolders...
Al CREATOR O'wWHER Full Cantral Subfolders and files anb
Allane SYSTEM Full Control Thisz folder, subfolders...

Allane zers [DMZTEST W sers]  Full Control Thiz folder, subfolders...

1| | 2|

Add... Edit... Bemove

i~ Allow inheritable permiszions from the parent to propagate to thiz object and all child objects. Include
theze with entries explicitly defined here.

™ Feplace permizzion entries on all child objects with entries shown here that apply to child objects

Learn more about access control.

k. I Cancel Apply

Step 24.13 - Click Apply

security =

"f You are about o change the permission settings an system folders, which can result in unexpected access problems and reduce security, Do you wank
] to conkinue?

Step 24.14 — Choose Yes.

Step 24.15 - Click OK to exit the editing mode.



Step 24.16 — Click OK to exit the permissions tab.
Step 24.17 — For each path in the below table, repeat the steps 24.7 — 24.16 above.

NOTE: Note which folders to apply the permissions to. The 1% column is the directory that you should navigate to and the 2™ column is the
collection of folders and files that you should apply these permissions onto.

Directory Apply onto
C:\Windows\System32 This Folder Only
C:\Windows\System32\inetsrv This Folder Only

C:\Program Files\Common Files This Folder, Subfolders and Files
E:\path_to your IS installation This Folder, Subfolders and Files

Step 25.0 — Change the Web Site to use the renamed IUSR account and associated password.
Step 25.1 — Go to Start > Programs > Administrative Tools > Internet Information Services (11S) Manager

Step 25.2 — Expand the trees down to your newly created web site.

lf; Internet Information Services (I15) Manager - | Ellﬂ
¥9 Fle  Action  View Window  Help =] =l
&= AW XERDE @2 E e
Eg Internet Information Services Marme | Path | Skat
=8 DMZ-HARD (local computer) =] default. htm

---_,_J &pplication Pools

El_,_J Webh Sites

¢ [ Default web Site (Stopped)

R Riest websice

- Web Service Extensions

4| | 1

Step 25.3 — Right click on your newly created web site and choose Properties > Directory Security

Step 25.4 — Under the Authentication and access control, click on Edit



Authentication Methods x|

—Iv Enable anonymous access:

Ilse the Following Windows user account For anonymous access:

Lser name: I Ohbscure_Mame_Here Browse, .. |

Passwiord: I Tl

—Authenticated access
For the following authentication methods, user name and password
are required when:

- anonymous access is disabled, or

- access is restricked using MTFS access conkrol lisks
[ Integrated Windows authentication
[ Digest authentication For Windows domain servers
[ Basic authentication {password is sent in clear bext)

[ .MET Passport authenticakion

Drefault domain: I Seleck, .. |
Realmn: | Seleck, .. |

| Ik I Zancel | Help |

Step 25.5 — Ensure that Enable anonymous access is checked.
Step 25.6 — For User Name: type in the renamed IUSR_<machinename> account from Step 23.3

Step 25.7 — For Password: type in the newly created password from Step 23.6 and click OK

Confirm Password x|

Pleaze re-enter the paszword ko confirm;

] I Cancel




Step 25.8 — You will have to re-enter the password again for validation and click OK.

Click OK to close the Properties window.

Step 25.9 — Open the Application Pools tab and choose the DefaultAppPool.

t—j Internet Information Services (I15) Manager

‘:g File  Action  Wiew  Window

Help

=10 x|

=181

e« a@m B[22y =

W:g Internet Information Services

= -1‘9 DMZ-HARD {local computer)
= Application Pools

=gk DefaulkappPool
v“f, Default Application
—#; Default Application

[l ) Web Sikes

test_website
----- ) web Service Extensions

3 Cief ault ‘Wweb Site (Stopped)

Description

| Path

L Default Application
Faulk Application

<Defaul Web Site =

<kest_website =

Step 25.10 — Right click on DefaultAppPool and select Properties > Performance.




DefaultAppPool Properties 7] x|

Recycling Performance |Health I Identity I

—Idle kimeouk

v Shutdown worker processes after being idle For =0
itime in minukes): :

—Request queue limit

[V Limit the kernel request queue inumber of requests): E, 4000

—I Enable CPU monitoring

Maximum CPU use (percentage): 100

Refresh CPU usage numbers {in minukes); E' 5

Action performed when CPU usage exceeds maximum CPL use;

IN::: ackion j

—Web garden

Maxirurm number af worker processes: E, 3
Ik I Cancel apply | Help |

Step 25.11 — Change the value under Web Garden > Maximum number of worker processes to 3 and click OK.

Step 26.0 — (Optional) Add a robots.txt file to prevent spidering.
Step 26.1 — In the root folder of your newly created website, add a file called robots.txt that includes the following syntax:

User Agent: *
Disallow: /

Step 27.0 — Firewall rules
Step 27.1 — Have your Network Admin Group set up the proper ACLs to allow traffic to your website.

Example ACL for router to permit SSH, HTTP, HTTPS, SNMP



access-list 150 permit tcp any host yourwebserver eq 80

access-list 150 permit tcp any host yourwebserver eq 443

access-list 150 permit tcp SSH Client networks yourwebserver eq 22
access-list 150 permit udp SNMP Server networks host yourwebserver eq 161
access-list 150 permit udp SNMP Server networks host yourwebserver eq 161
access-list 150 permit udp SNMP Server networks host yourwebserver eq 162
access-list 150 permit udp SNMP Server network host yourwebserver eq 162
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